Browser Security Update

IMPORTANT CUSTOMER NOTICE

We will soon be updating the minimum browser standards required to use Business On Line, Business On Line File Gateway and Business On Line Payments Plus.

What does this mean?

As part of Bank of Ireland’s ongoing drive to strengthen the security and confidentiality of customer information, we will be making further enhancements to the security of the Bank of Ireland Group websites, including Business On Line, Business On Line File Gateway and Business On Line Payments Plus.

How will this affect you?

Customers using older versions of internet browsers will no longer be able to log on to Business On Line, Business On Line File Gateway and Business On Line Payments Plus.

What do you need to do?

You may need to update your internet browser to access Business On Line, Business On Line File Gateway and Business On Line Payments Plus.

What versions of Internet Browsers Can I use?

Internet browsers:

  • Microsoft Internet Explorer Version 11 or higher
  • Mozilla Firefox Version 27 or higher
  • Google Chrome Version 30 or higher
  • Safari Version 6 or higher

For additional information about online security, please click here.

Remember: Bank of Ireland will never text you asking you to update your software or ask you for your online banking information.